Intermittent Debit / Credit Card Purchases Issue
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Dec 13, 2024 - 11:04 UTC
Identified
We have identified intermittent issues with debit / credit card purchases, and the addition of new cards, through our Consumer Web app only. Some clients might be experiencing failed transactions temporarily. We are working to resolve the issue and will provide any updates as soon as possible.
Posted Dec 13, 2024 - 10:57 UTC
This incident affected: Payment Methods (Debit / Credit Cards).