Intermittent Issues with Custody Service

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 15:17 UTC

Investigating

We are currently investigating an issue affecting a subset of operations within our Custody service. Some clients may be experiencing degraded performance or failures when interacting with custody-related features. Our engineering teams are engaged and working to identify the root cause. We will provide updates as more information becomes available.
Posted Sep 10, 2025 - 15:15 UTC
This incident affected: Kraken Institutional (Custody User Interface).