Issues creating virtual account orders on Banking Circle

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 16:06 UTC

Investigating

We are investigating an issue affecting the creation of new virtual accounts on Banking Circle.

Existing accounts are not known to be affected at this time. We are working to restore normal functionality and will provide an update as more information becomes available.
Posted Aug 13, 2026 - 11:50 UTC