Network-Wide Sui Mainnet Halt

Incident Report for Kraken

Investigating

Issue recurred. We are continuing investigation.
Posted May 29, 2026 - 12:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 29, 2026 - 11:09 UTC

Update

We are continuing to investigate this issue.
Posted May 28, 2026 - 15:28 UTC

Investigating

We are aware of an ongoing outage on the Sui network affecting Sui Mainnet, Testnet, and Devnet. This is an issue on the Sui network itself and impacts all platforms that interact with Sui.

We are monitoring the situation and will update once the Sui network resumes normal operation.
Posted May 28, 2026 - 15:26 UTC
This incident affects: Earn (Sui (SUI) - Staking) and Digital Currency Funding (Sui (SUI)).