Juno (JUNO) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Feb 08, 2024 - 10:27 UTC
Identified
We have identified an issue with the Juno (JUNO) funding gateway. Deposits and withdrawals may be delayed at this time. All other funding methods are operating normally. We are working diligently to resolve the issue and will keep you updated.
Posted Feb 08, 2024 - 09:07 UTC
This incident affected: Digital Currency Funding (Juno (JUNO)).