"Pay with balance" not working on Kraken Pro Web for Prop purchases

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 16:48 UTC

Investigating

We are currently investigating an issue that prevents clients from paying using their balance for Kraken Prop evaluations.
Posted Jul 31, 2026 - 16:03 UTC
This incident affected: Prop Trading.