Historical Balances Display Issue on Kraken Web and Mobile

Incident Report for Kraken

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 08, 2026 - 12:37 UTC

Identified

We are currently investigating an issue affecting the calculation of Historical Balances. Some users may see the latest historical balance data temporarily unavailable due to a delay in daily fiat FX rates from an external provider. Previously displayed balances remain accurate. We are monitoring the situation and will provide updates as more information becomes available.
Posted Feb 08, 2026 - 09:42 UTC
This incident affects: Website, Kraken App, and Kraken Pro App.