Issues Loading Explore Section in Kraken Wallet

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 12:48 UTC

Investigating

We are investigating an issue causing the Explore section in the Kraken Wallet App to fail to load for some clients. Core wallet functionality remains available and unaffected. Our team is actively working to identify the cause and restore normal service. We will provide further updates as progress is made.
Posted Jun 19, 2026 - 09:35 UTC
This incident affected: Kraken Wallet.