Live Chat Unavailable

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Feb 01, 2021 - 12:30 UTC

Investigating

We are investigating an issue with our Live Chat widget. Support via Live Chat is currently unavailable.
Posted Feb 01, 2021 - 11:56 UTC
This incident affected: Support.