Historical Balances Display Issue on Kraken Web and Mobile

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted May 22, 2025 - 12:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 22, 2025 - 11:52 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 22, 2025 - 11:03 UTC

Investigating

We are currently investigating an issue where historical balances and portfolio PnL data may be missing or inaccurate on Kraken Web and Mobile platforms. Trading functionality remains unaffected. Our engineering teams are actively working to identify and resolve the issue. We will provide updates as more information becomes available.
Posted May 22, 2025 - 10:50 UTC
This incident affected: Website and Mobile Applications.