We are aware of an issue with PayAmigo, that is affecting Argentine Peso (ARS), Brazilian Real (BRL) and Mexican Peso (MXN) funding. As a result, users may be unable to deposit or withdraw ARS and MXN, aross all Kraken products. All other funding methods are operating normally. We will provide updates as soon as more information becomes available.
Posted Apr 19, 2026 - 20:38 UTC
Investigating
We are aware of an issue with PayAmigo, that is affecting Argentine Peso (ARS) and Mexican Peso (MXN) funding. As a result, users may be unable to deposit or withdraw ARS and MXN, aross all Kraken products. All other funding methods are operating normally. We will provide updates as soon as more information becomes available.
Posted Apr 19, 2026 - 20:26 UTC
This incident affected: Payment Methods (Argentine Peso (ARS) - Domestic, Brazilian Real (BRL) - Domestic, Mexican Peso (MXN) - Domestic).